Vauxhall Mokka Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,
I have a 2014 model mokka 1.4 enjoy automatic car.
When I started my vehicle, the radio on / off button was not working and there was no display on the clock and outside temperature indicator on the center panel.
The f31 in the fuse box controlling the infotainment system controlled the indicators on the front panel, while the f32 and f33 controlled the infotainment systems. f31 was a 5 amp blade fuse, f32 was a 15 amp fuse, and f33 was a 10 amp fuse. When a different fuse was inserted instead of the F32, a radio sound came from the speaker, but the keys on the radio and the screen were still missing. I disassembled and installed the battery terminal again, there was no solution.
I could not find the cause of the error, I would be glad if the experienced friends make an urgent return. Greetings.
 

·
Registered
Joined
·
756 Posts
Could the radio be broke .needs taking out and get repaired
 

·
Registered
Joined
·
756 Posts
I think the screen is separate from the radio .the screen only shows what the radio signal sends .the radio is separate from screen .
 

·
Registered
Joined
·
135 Posts
The radio, top screen and the DIC ( screen between speeo and tacho) are totally integrated with the rest of the cars electronics (ECU etc), and as far as I know there is a connection from the back of the radio/CD module to the top screen. Noted on this diagram as info display module.

1479


Not sure what version of Infotainmnet this is, but the principle is the same accross the range.
 
1 - 5 of 5 Posts
Top