Vauxhall Mokka Forums banner
41 - 52 of 52 Posts

·
Registered
Joined
·
13 Posts
I had exactly the same problem but it was resolved.
We needed a new flywheel which fortunately we were able to have replaced under the lifetime 7 year warranty as we had had the car from new.
Since then we have had no issues. Diagnostic checks show no fault issues.
Good luck.
Hi John
Thanks for letting me know. So is it possible that I won’t need a new clutch and will only need the flywheel? Or do people have the clutch done at the same time due to the labour costs anyway? (Sorry i’m crap with cars and have no idea when it comes to the mechanics of them!).
 

·
Registered
Joined
·
5 Posts
Hi Clare
I am having the same issues with my vehicle which is also a 2013 1.7 CDTi and it has also developed a rattling noise. I have booked it into the garage for Monday but just wondered if I would need to have all of this work done for the problem to resolve or just the DM and clutch do you know? Thanks in advance.
Hiya, so the DM and clutch didn’t solve the problem, it was the battery that actually stopped the problem.
I had my DM and clutch done because when it happened which was inconsistent my clutch peddle would stick. But the pedal only stuck when it wouldn’t start, they replaced my clutch and DM and said it needed doing anyway but the stop start problem still happened With a horrendous rattle.
Got it serviced, fuel filter change, glow plugs and new battery and has been sweet since
 

·
Registered
Joined
·
13 Posts
Hiya, so the DM and clutch didn’t solve the problem, it was the battery that actually stopped the problem.
I had my DM and clutch done because when it happened which was inconsistent my clutch peddle would stick. But the pedal only stuck when it wouldn’t start, they replaced my clutch and DM and said it needed doing anyway but the stop start problem still happened With a horrendous rattle.
Got it serviced, fuel filter change, glow plugs and new battery and has been sweet since
Thanks for getting back to me. I have had been experiencing the same issue with the vehicle not starting on occasion (only when warm) and the loud tractor type clatter noise that people have mentioned along with the clutch pedal sticking to the floor.
From reading various comments some people have said its the battery and same people have said it was down to the DM. However mine has also developed a strange chug chug type noise (like a train) when the clutch pedal is down so thinking it possibly is more down to the DM/clutch.
 

·
Registered
Joined
·
2 Posts
Hi Guys,im having a nightmare with my Mokka 2013 SE 1.7TDCI 4WD

please see video below

[TUBE]e3VlIPHT_jg[/TUBE]


i turn ignition on (once) , with foot down on the clutch, as you can see engine tries to start 4 times before i turn ignition off. clutch pedal stays stuck half way when i remove my foot, and i have to pull it up with my foot!

this keeps happening very often. after a few tries (and pressing the gas pedal repeatedly) the engine will say on!

this happen when the engine was hot.

do you have any advice ?
Did you get this fixed? Mine does the same!! 🙄
 

·
Administrator
Joined
·
10,731 Posts
That sounds rather expensive? :eek:
 

·
Registered
Joined
·
13 Posts
That sounds rather expensive? :eek:
It was... £1500 😫
A couple of days later and the ‘service vehicle soon’ light has come on which they have told me is the glow plugs and it will cost £240 to replace the glow plugs and relay.
Earlier in the year, it had to have a new fuel pump primer and fuel
Temperature sensor which was a £1000. Not been a good year all in all. Hoping I’ve just been unlucky and they’re not all prone to these faults!
 

·
Registered
Joined
·
2 Posts
Hi Guys,im having a nightmare with my Mokka 2013 SE 1.7TDCI 4WD

please see video below

[TUBE]e3VlIPHT_jg[/TUBE]


i turn ignition on (once) , with foot down on the clutch, as you can see engine tries to start 4 times before i turn ignition off. clutch pedal stays stuck half way when i remove my foot, and i have to pull it up with my foot!

this keeps happening very often. after a few tries (and pressing the gas pedal repeatedly) the engine will say on!

this happen when the engine was hot.

do you have any advice ?
Hi mate
Did you resolve this starting issue, my mokka does the same.

Sndy
 

·
Administrator
Joined
·
10,731 Posts

·
Registered
Joined
·
9 Posts
Hi

I'm having same issue did the fuel filter sort the job out for you.

Andy.
Isn't fuel filter in the fuel tank
Hi, the fuel filter on mine is underneath by the back wheel passenger side. ive just put a post on, as mine was having the same problem, I know it sounds daft but changing the battery for a new one did the trick on mine.
 
41 - 52 of 52 Posts
Top